[PHP] Composer [Tips]
#1

Bonjour,

Relativement à PHP, il existe l'outil Composer, bien pratique. Sous OpenBSD, nous l'avons en tant que package, un peu daté, mais ce n'est pas grave...

Dès l'installation, on fait une mise à jour...

Code :
# pkg_add composer
# composer selfupdate


Il est configuré pour php-7.0 !!!
Si vous utilisez php-7.2, sous 6.4, voire php-7.3 sous 6.5, afin que composer fonctionne correctement avec ces environnements PHP, il suffit de modifier le fichier de lancement de composer :

Code :
# sed -i -e "s/php-7.0/php-7.x/" "$(which composer)"

(remplacer 7.x, par votre version de PHP, soit 7.2 ou 7.3)

Puis on lance un petit diagnostic, histoire de s'assurer que tout est bon !

Code :
$ composer diagnose
Checking platform settings: OK
Checking git settings: OK
Checking http connectivity to packagist: OK
Checking https connectivity to packagist: OK
Checking github.com rate limit: OK
Checking disk free space: OK
Checking pubkeys:
Tags Public Key Fingerprint: 57815BA2 7E54DC31 7ECC7CC5 573090D0  87719BA6 8F3BB723 4E5D42D0 84A14642
Dev Public Key Fingerprint: 4AC45767 E5EC2265 2F0C1167 CBBB8A2B  0C708369 153E328C AD90147D AFE50952
OK
Checking composer version: OK
Composer version: 1.8.5
PHP version: 7.2.17
PHP binary path: /usr/local/bin/php-7.2

GPG:Fingerprint ed25519 : 072A 4DA2 8AFD 868D 74CF  9EA2 B85E 9ADA C377 5E8E
GPG:Fingerprint rsa4096 : 4E0D 4AF7 77F5 0FAE A35D  5B62 D0FF 7361 59BF 1733
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)