WiFi or not WiFi ?
#1
Photo 

Bonjour,

isotop-0.2.1-amd64-full
[/url]
J'ai un petit souci avec le WiFi.
Une fois l'installation terminée, voilà ce que ça donne quand j'essaie de le configurer avec l'outil qui va bien :

[url=https://framapic.org/7q0G5T4OgiEi/Qwm6hcefZfMR][Image: Qwm6hcefZfMR]

[Image: fI7bF3Ibkg1v]

[Image: BSdbnOcPLmse]

Les réseaux joignables sont bien détectés et, bien que je sois supposé être connecté, je ne le suis pas.

# ifconfig athn0
athn0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
        lladdr 00:13:d3:dc:6c:9e
        index 1 priority 4 llprio 3
        trunk: trunkdev trunk0
        groups: wlan
        media: IEEE802.11 autoselect (DS1 mode 11g)
        status: no network
        ieee80211: nwid alijorfree wpakey 0x520093c4f8e31f1c011daf1fe51a34b37b597f12fbe6c5fe69917e5ad6ca1187 wpaprotos wpa2 wpaakms psk wpaciphers ccmp wpagroupcipher ccmp

Un espoir de faire fonctionner le truc ou un problème propriétaire ?

J'ai quand même cherché un peu (si, si) mais sans trouver de solution évidente...

P.S. : je ne connais quasiment rien aux *BSD.

Merci.
Répondre
#2

Salut,
peux-tu "pinger" sans faire de résolution de nom de domaine ?
Code :
ping 8.8.8.8

Ça retourne quoi ?
Répondre
#3

Sans connexion ethernet mais avec une connexion WiFi théorique :

$ ping 8.8.8.8

PING 8.8.8.8 (8.8.8.8): 56 data bytes

C'est tout. Pas top, hein ?
Répondre
#4

(02-11-2017, 12:59:00)christophe60_fr a écrit :  Bonjour,

Les réseaux joignables sont bien détectés et, bien que je sois supposé être connecté, je ne le suis pas.

Code :
# ifconfig athn0
athn0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
        lladdr 00:13:d3:dc:6c:9e
        index 1 priority 4 llprio 3
        trunk: trunkdev trunk0
        groups: wlan
        media: IEEE802.11 autoselect (DS1 mode 11g)
        status: no network
        ieee80211: nwid alijorfree wpakey 0x520093c4f8e31f1c011daf1fe51a34b37b597f12fbe6c5fe69917e5ad6ca1187 wpaprotos wpa2 wpaakms psk wpaciphers ccmp wpagroupcipher ccmp

Si tu penses qu'il te manque un firmware, lance
Code :
fw_update

Pour être sûr que ton wifi est chiffré comme tu le crois et pas en WPA1, un petit
Code :
ifconfig athn0 scan
ne nuira pas.

J'ai déjà eu des soucis pour me connecter à des réseaux en WPA1, en gros il fallait que je précise le
Code :
wpaprotos wpa1
lors d'un deuxième appel à ifconfig sinon il ne le prenait pas en compte.
( Peut-être que l'ordre des paramètres donné à ifconfig à de l'importance ? Je ne sais pas, je n'ai pas creusé plus loin …)

Tu n'as pas d'adresse.
Si tu n'as pas vu passer "Getting an IP address via DHCP",
ça vaut peut-être la peine de lancer
Code :
dhclient athn0
manuellement histoire de voir si le serveur dhcp t'en donne une.

Je n'ai pas d'autre idée pour l'instant, mais peut-être que la sortie de ces commandes m'en donnera.
Répondre
#5

Code :
fw_update

ne m'a jamais rien donné.

$ doas ifconfig athn0 scan
doas (jo@PC-de-JO.my.domain) password:
athn0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
        lladdr 00:13:d3:dc:6c:9e
        index 1 priority 4 llprio 3
        trunk: trunkdev trunk0
        groups: wlan
        media: IEEE802.11 autoselect (DS1 mode 11g)
        status: no network
        ieee80211: nwid alijorfree wpakey 0x520093c4f8e31f1c011daf1fe51a34b37b597f12fbe6c5fe69917e5ad6ca1187 wpaprotos wpa2 wpaakms psk wpaciphers ccmp wpagroupcipher ccmp
                nwid FreeWifi_secure chan 6 bssid f4:ca:e5:e6:da:f2 -33dBm 54M privacy,short_slottime,wpa2,802.1x
                nwid alijorfree chan 6 bssid f4:ca:e5:e6:da:f0 -34dBm 54M privacy,short_slottime,wpa1
                nwid FreeWifi chan 6 bssid f4:ca:e5:e6:da:f1 -34dBm 54M short_slottime

Là, par contre, comme tu le dis plus bas, je constate que le réseau auquel je veux me connecter est en wpa1 et non wpa2.

En précisant 
Code :
wpaprotos wpa1
ça change tout :

$ doas ifconfig athn0 scan
doas (jo@PC-de-JO.my.domain) password:
athn0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
       lladdr 00:13:d3:dc:6c:9e
       index 1 priority 4 llprio 3
       trunk: trunkdev trunk0
       groups: wlan
       media: IEEE802.11 autoselect (OFDM6 mode 11g)
       status: active
       ieee80211: nwid alijorfree chan 6 bssid f4:ca:e5:e6:da:f0 -30dBm wpakey 0x520093c4f8e31f1c011daf1fe51a34b37b597f12fbe6c5fe69917e5ad6ca1187 wpaprotos wpa1 wpaakms psk wpaciphers tkip,ccmp wpagroupcipher tkip
               nwid alijorfree chan 6 bssid f4:ca:e5:e6:da:f0 -30dBm 54M privacy,short_slottime,wpa1
               nwid FreeWifi chan 6 bssid f4:ca:e5:e6:da:f1 -30dBm 54M short_slottime
               nwid FreeWifi_secure chan 6 bssid f4:ca:e5:e6:da:f2 -31dBm 54M privacy,short_slottime,wpa2,802.1x[/code]

Sans connexion ethernet, pour l'instant, c'est tout bon.
Je vais redémarrer l'engin, histoire de voir ce que ça donne.

Au reboot, ça ne tient pas. Dommage...



        i
Répondre
#6

(02-11-2017, 22:11:18)christophe60_fr a écrit :  Là, par contre, comme tu le dis plus bas, je constate que le réseau auquel je veux me connecter est en wpa1 et non wpa2.

Au reboot, ça ne tient pas. Dommage...

Si tu as la main sur alijorfree, change le en wpa2 et ça résoudra une partie de ton problème
voire ton problème en entier, sinon il va falloir que tu ajoutes le support pour wpa1 à owi.

Pour ton autre réseau, freewifi_secure, il te faudra wpa_supplicant.
Répondre
#7

Je dirais même mieux, il devrait déjà être en WPA2 depuis longtemps ! Wink

GPG:Fingerprint ed25519 : 072A 4DA2 8AFD 868D 74CF  9EA2 B85E 9ADA C377 5E8E
GPG:Fingerprint rsa4096 : 4E0D 4AF7 77F5 0FAE A35D  5B62 D0FF 7361 59BF 1733
Répondre
#8

(02-11-2017, 23:09:40)eol a écrit :  Pour ton autre réseau, freewifi_secure, il te faudra wpa_supplicant.

Il faut pas la carte sim sécurisé de free, pour la connexion a ce réseau ?.
Répondre
#9

owi ne gère que le wpa2, je n'ai pas implémenté le WEP ou wpa1...
Tu devras donc t'en passer pour l'instant pour te connecter, en éditant directement le fichier /etc/hostname.athn0 à la main.
Une fois l'édition terminée, tu peux lancer la connexion ainsi :
Code :
sh /etc/netstart

Par ailleurs, owi crée un fichier hostname.trunk0 si une interface filaire est détectée (pour passer direcement du filaire au WiFi si l'un disparaît). Supprime ce fichier s'il est toujours présent.

Si besoin, nous reprendrons ensemble toute la configuration à zero, ta carte WiFi est connue d'OpenBSD et va fonctionner.
Répondre
#10

Bonjour :-)

Ma réponse : Not wifi... Ok, désolé mais je n'ai pas pu m'en empêcher. Allez je sors -> [] ;-)

Un OS pour les gouverner tous (FreeBSD), un jail pour les trouver (Unbound)
Un filesystem pour les amener tous et dans les ténèbres les lier (ZFS) ;)
Répondre
#11

Rien de mieux pour l'instant.

Fichier /etc/hostname.athn0 modifié en rajoutant :

Code :
wpa

wpaprotos wpa2
entre l'ESSID et la clef.

Ce qui n'est peut-être pas ce qui se fait de mieux (?)

Au reboot, ce fichier est reconfiguré automatiquement comme avant (les modif. disparaissent).
Répondre
#12

Ok, plus de souci.
Je me suis contenté de faire comme suggéré, à savoir :
Code :
Si tu as la main sur alijorfree, change le en wpa2 et ça résoudra une partie de ton problème
et c'est nickel.

Me demande maintenant si ça ne risque pas de poser problème au niveau de l'imprimante (WiFi). Ca me rappelle vaguement quelque chose qui ne date pas d'hier --> à suivre...

En tout cas, merci pour tout.
Répondre
#13

Kobol a raison.
Freewifi-secure est reservé aux téléphones protables chez free. Le protocole est wpa-psk et ça passe par l'identification de la carte sim.
À une époque je me suis arraché les cheveux pour tenter de patcher cyanogenMod pour ajouter ce protocale. Rien à faire ...
Il n'y a que les roms android avec la surcouche free (et peut être les autres opérateurs) qui fournissaient cette option. D'ailleurs les téléphones dans les offres free ne sont pas tous compatibles wpa-psk.
Ça c'était à l'époque ...

À part ça, je serais un peu plus méfiant avant de poster nwid et wpakey en clair comme ça.
Répondre
#14

(04-11-2017, 22:07:29)Funkygoby a écrit :  Kobol a raison.
Freewifi-secure est reservé aux téléphones protables chez free. Le protocole est wpa-psk et ça passe par l'identification de la carte sim.
À une époque je me suis arraché les cheveux pour tenter de patcher cyanogenMod pour ajouter ce protocale. Rien à faire ...
Il n'y a que les roms android avec la surcouche free (et peut être les autres opérateurs) qui fournissaient cette option. D'ailleurs les téléphones dans les offres free ne sont pas tous compatibles wpa-psk.
Ça c'était à l'époque ...

À part ça, je serais un peu plus méfiant avant de poster nwid et wpakey en clair comme ça.

Merci, ça fait plaisir de temps en temps. Sleepy Dodgy Idea

Si la méthode de sécurisation est intéressante, je me pose la question du contrôle ?. Est-ce que c'est l'utilisateur qui a le contrôle ou l'opérateur qui contrôle l'utilisateur ?.
Répondre
#15

(03-11-2017, 00:36:31)Kobol a écrit :  
(02-11-2017, 23:09:40)eol a écrit :  Pour ton autre réseau, freewifi_secure, il te faudra wpa_supplicant.

Il faut pas la carte sim sécurisé de free, pour la connexion a ce réseau ?.

Indépendamment du coté matériel où il faudra en effet la carte sim,
( et aussi un lecteur de carte tant qu'on y est )
ifconfig ne gère pas l'EAP, d'où la mention à wpa_supplicant.
Répondre
#16

(05-11-2017, 19:38:23)eol a écrit :  
(03-11-2017, 00:36:31)Kobol a écrit :  
(02-11-2017, 23:09:40)eol a écrit :  Pour ton autre réseau, freewifi_secure, il te faudra wpa_supplicant.

Il faut pas la carte sim sécurisé de free, pour la connexion a ce réseau ?.

Indépendamment du coté matériel où il faudra en effet la carte sim,
( et aussi un lecteur de carte tant qu'on y est )
ifconfig ne gère pas l'EAP, d'où la mention à wpa_supplicant.

Non, NON !

Technicien de Free: " C'est soit l'appareil gére EAP ou soit c'est l'installation de l'application android de Free"

Sinon, pas de Free_secure !.
Répondre
#17

(05-11-2017, 22:12:23)Kobol a écrit :  Non, NON !

Technicien de Free: " C'est soit l'appareil gére EAP ou soit c'est l'installation de l'application android de Free"

Sinon, pas de Free_secure !.

Tu as tout à fait le droit de croire le technicien.
https://ohnomoregadgets.wordpress.com/20...-computer/
Répondre
#18

Euh, @"eol" et @"Kobol" , je vous prierai de rester concentré sur le sujet du post.
Vous êtes entrain de vous éloigner de la nécessité d'aide !

Merci d'y veiller.

GPG:Fingerprint ed25519 : 072A 4DA2 8AFD 868D 74CF  9EA2 B85E 9ADA C377 5E8E
GPG:Fingerprint rsa4096 : 4E0D 4AF7 77F5 0FAE A35D  5B62 D0FF 7361 59BF 1733
Répondre
#19

(06-11-2017, 10:49:40)PengouinBSD a écrit :  Euh, @"eol" et @"Kobol" , je vous prierai de rester concentré sur le sujet du post.

C'est vrai, nous sommes hors-sujet …


(06-11-2017, 10:49:40)PengouinBSD a écrit :  Vous êtes entrain de vous éloigner de la nécessité d'aide !

La nécessité d'aide, c'est fait. Wink
Je crois que le sujet initial est résolu depuis le 03-11-2017, 13:08:04
Répondre
#20

Désolé, j'ai eu quelques menus soucis de connexion au forum.
Mais oui, souci résolu.
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)